Tag Archives: Tomcat Error

The Apache Tomcat installation at this directory is version 8.5.5. A Tomcat 8.0 installation is expected.

When I was configuring Tomcat Server in SpringSource Tool Suite, I got the following error:

The Apache Tomcat installation at this directory is version 8.5.5. A Tomcat 8.0 installation is expected.

 

This is basically the problem with Tomcat it seems as per the forums and other resources. But you can fix the issue as the STS was looking for version 8.0 by editing the ServerInfo.properties in the jar file “\lib\catalina.jar” in the Tomcat installation server.

If you are using Bash like me here are the steps you need to make in order to fix the error:

$ cd lib
$ mkdir catalina
$ cd catalina/
$ unzip ../catalina.jar
$ vim org/apache/catalina/util/ServerInfo.properties
$ jar uf ../catalina.jar org/apache/catalina/util/ServerInfo.properties
$ cd..
$ rm -rf catalina

 

The serverInfo.properties file should be as below:

server.info=Apache Tomcat/8.0.0
server.number=8.5.5.0
server.built=Aug 31 2016 19:51:16 UTC

 

Note that it is just enough if you change “server.info” property and no need to change other information. They can stay as it is.

Now the issue should be fixed and you can continue with your work.

Note: If you are working on Windows, then you do not need to follow the above steps and you can use any archive tools like WinRar or Winzip and go to the location org/apache/catalina/util/ServerInfo.properties and make the change.

Hope this helps!!!